再起動してもSSIDが出てこない


#1

こんにちは

おかげさまで、candy piの接続がうまくいったので、今度は、モバイルルーターとして使えるようにセットアップしております。ここの設定例をそのまま使いました。

RaspberryPi(Raspbian)でモバイルルーターとして使用する設定
https://candy-line.gitbooks.io/candy-pi-lite/content/configuration/rpi-router.html

で、再起動してもSSIDが見えません。
同じ設定を2回やっているので多分大丈夫だと思います。
再起動の際には有線LANは抜いています。

pi@raspberrypi:~ $ dpkg -l dnsmasq hostapd
要望=(U)不明/(I)インストール/®削除/§完全削除/(H)保持
| 状態=(N)無/(I)インストール済/©設定/(U)展開/(F)設定失敗/(H)半インストール/(W)トリガ待ち/(T)トリガ保留
|/ エラー?=(空欄)無/®要再インストール (状態,エラーの大文字=異常)
||/ 名前 バージョン アーキテクチャ 説明
++±=========================-=================-=================-========================================================
ii dnsmasq 2.76-5+rpt1+deb9u all Small caching DNS proxy and DHCP/TFTP server
ii hostapd 2:2.4-1+deb9u2 armhf IEEE 802.11 AP and IEEE 802.1X/WPA/WPA2/EAP Authenticato

気が付いたのは、再起動するたびに設定した

/boot/boot-ip.json

が消えるのです。これが原因なんだと思いますが、消える原因と対策がわかりません。
なにか気が付くことがあれば教えてください。
よろしくお願いします。


#2

ところで、

ここで、 *filter と書かれた先頭の方にある設定の に、以下の行を追加します。

とありますが、こんなのでいいのでしょうか?

$ sudo cat /etc/ufw/before.rules

rules.before

Rules that should be run before the ufw command line added rules. Custom

rules should be added to one of these chains:

ufw-before-input

ufw-before-output

ufw-before-forward

NAT table rules

*nat
:POSTROUTING ACCEPT [0:0]

Forward traffic through ppp0

-A POSTROUTING -o ppp0 -j MASQUERADE

don’t delete the ‘COMMIT’ line or these nat table rules won’t

be processed

COMMIT

Don’t delete these required lines, otherwise there will be errors

*filter
:ufw-before-input - [0:0]
:ufw-before-output - [0:0]
:ufw-before-forward - [0:0]
:ufw-not-local - [0:0]

End required lines


#3

ちなみにwlan0は上がっていないようです。

$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether b8:27:eb:b7:fc:38 brd ff:ff:ff:ff:ff:ff
inet 192.168.2.50/24 brd 192.168.2.255 scope global eth0
valid_lft forever preferred_lft forever
inet6 fe80::1964:9bfe:712b:86ab/64 scope link
valid_lft forever preferred_lft forever
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
link/ether b8:27:eb:e2:a9:6d brd ff:ff:ff:ff:ff:ff
5: ppp0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 3
link/ppp
inet 10.59.116.54 peer 10.64.64.64/32 scope global ppp0
valid_lft forever preferred_lft forever


#4

ご質問ありがとうございます。
確認ですが、ベースとなるOSイメージは、どのファイルでしょうか?
ご利用になったファイルの種類(Raspbian Desktop/Lite/CANDY Pi Lite専用)とバージョンを教えていただけますか。

また、/boot/boot-ip.jsonが消えるのは正常動作です。設定がうまくいかない場合のみ消えずに残ったままになります。

追加の質問のRulesファイルの中身ですが、エディターによって表示内容が変わってしまっていますので、「```」で囲んでいただけますでしょうか(こちらに紹介されているような書き方です)。お手数をおかけしますが、よろしくお願いいたします。


#5

サポートありがとうございます。

ベースとなるOSイメージは最新の「OSイメージアップデート v5.2.0」です。
https://github.com/CANDY-LINE/candy-pi-lite-os-image/releases/download/5.2.0/image_2018-11-13-candy-pi-lite-raspbian-lite-ja_JP.zip

/etc/ufw/before.rulesはこのように記述しております。

$ sudo cat /etc/ufw/before.rules
#
# rules.before
#
# Rules that should be run before the ufw command line added rules. Custom
# rules should be added to one of these chains:
#   ufw-before-input
#   ufw-before-output
#   ufw-before-forward
#

# NAT table rules
*nat
:POSTROUTING ACCEPT [0:0]

# Forward traffic through ppp0
-A POSTROUTING -o ppp0 -j MASQUERADE

# don't delete the 'COMMIT' line or these nat table rules won't
# be processed
COMMIT

# Don't delete these required lines, otherwise there will be errors
*filter
:ufw-before-input - [0:0]
:ufw-before-output - [0:0]
:ufw-before-forward - [0:0]
:ufw-not-local - [0:0]
# End required lines


# allow all on loopback
-A ufw-before-input -i lo -j ACCEPT
-A ufw-before-output -o lo -j ACCEPT

# quickly process packets for which we already have a connection
-A ufw-before-input -m conntrack --ctstate RELATED,ESTABLISHED -j ACCEPT
-A ufw-before-output -m conntrack --ctstate RELATED,ESTABLISHED -j ACCEPT
-A ufw-before-forward -m conntrack --ctstate RELATED,ESTABLISHED -j ACCEPT

# drop INVALID packets (logs these in loglevel medium and higher)
-A ufw-before-input -m conntrack --ctstate INVALID -j ufw-logging-deny
-A ufw-before-input -m conntrack --ctstate INVALID -j DROP

# ok icmp codes for INPUT
-A ufw-before-input -p icmp --icmp-type destination-unreachable -j ACCEPT
-A ufw-before-input -p icmp --icmp-type source-quench -j ACCEPT
-A ufw-before-input -p icmp --icmp-type time-exceeded -j ACCEPT
-A ufw-before-input -p icmp --icmp-type parameter-problem -j ACCEPT
-A ufw-before-input -p icmp --icmp-type echo-request -j ACCEPT

# ok icmp code for FORWARD
-A ufw-before-forward -p icmp --icmp-type destination-unreachable -j ACCEPT
-A ufw-before-forward -p icmp --icmp-type source-quench -j ACCEPT
-A ufw-before-forward -p icmp --icmp-type time-exceeded -j ACCEPT
-A ufw-before-forward -p icmp --icmp-type parameter-problem -j ACCEPT
-A ufw-before-forward -p icmp --icmp-type echo-request -j ACCEPT

# allow dhcp client to work
-A ufw-before-input -p udp --sport 67 --dport 68 -j ACCEPT

#
# ufw-not-local
#
-A ufw-before-input -j ufw-not-local

# if LOCAL, RETURN
-A ufw-not-local -m addrtype --dst-type LOCAL -j RETURN

# if MULTICAST, RETURN
-A ufw-not-local -m addrtype --dst-type MULTICAST -j RETURN

# if BROADCAST, RETURN
-A ufw-not-local -m addrtype --dst-type BROADCAST -j RETURN

# all other non-local packets are dropped
-A ufw-not-local -m limit --limit 3/min --limit-burst 10 -j ufw-logging-deny
-A ufw-not-local -j DROP

# allow MULTICAST mDNS for service discovery (be sure the MULTICAST line above
# is uncommented)
-A ufw-before-input -p udp -d 224.0.0.251 --dport 5353 -j ACCEPT

# allow MULTICAST UPnP for service discovery (be sure the MULTICAST line above
# is uncommented)
-A ufw-before-input -p udp -d 239.255.255.250 --dport 1900 -j ACCEPT

# don't delete the 'COMMIT' line or these rules won't be processed
COMMIT

なお、wlan0:は上がっていないようです。

$ sudo ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether b8:27:eb:b7:fc:38 brd ff:ff:ff:ff:ff:ff
    inet 192.168.2.50/24 brd 192.168.2.255 scope global eth0
       valid_lft forever preferred_lft forever
    inet6 fe80::1964:9bfe:712b:86ab/64 scope link
       valid_lft forever preferred_lft forever
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether b8:27:eb:e2:a9:6d brd ff:ff:ff:ff:ff:ff
5: ppp0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 3
    link/ppp
    inet 10.59.116.54 peer 10.64.64.64/32 scope global ppp0
       valid_lft forever preferred_lft forever

インターネット接続はできているようです。

$ ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=2 ttl=119 time=81.1 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=119 time=59.4 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=119 time=46.6 ms
64 bytes from 8.8.8.8: icmp_seq=5 ttl=119 time=43.7 ms
64 bytes from 8.8.8.8: icmp_seq=6 ttl=119 time=41.9 ms

#6

ありがとうございます。

試された手順で抜けている箇所があるかもしれません。
専用OSイメージをご利用の場合は、手順通り進めると次のようなコマンドを実行していくのが正しいのですが、実施していない内容はありますでしょうか?

$ sudo systemctl stop candy-pi-lite
$ sudo nano /etc/default/ufw
$ sudo nano /etc/ufw/before.rules
$ sudo nano /etc/sysctl.conf
$ sudo nano /boot/boot-ip.json
$ sudo mv /etc/dnsmasq.conf /etc/dnsmasq.conf.orig
$ sudo nano /etc/dnsmasq.conf
$ sudo nano /etc/hostapd/hostapd.conf
$ sudo nano /etc/default/hostapd
$ sudo systemctl enable dnsmasq
$ sudo systemctl enable hostapd
$ sudo reboot

historyコマンドを実行していただくとこれまでに実行した履歴をご覧になれますので、ご確認いただけますか。こちらでは、上記手順にてwlan0がupしています。

また、/etc/ufw/before.rulesは、ご提示いただいた内容で問題ありません。


#7

ありがとうございます。

もう一度、いただいたコマンドを順番に実行しましたが、SSIDはまだ出てきません。
wlan0もdownしたままです。

ところで、ssid名とパスワードの長さは何バイトでもいいのでしょうか?

ssid=aaaaa
wpa_passphrase=bbbbb

$ cat /etc/default/ufw
# /etc/default/ufw
#

# Set to yes to apply rules to support IPv6 (no means only IPv6 on loopback
# accepted). You will need to 'disable' and then 'enable' the firewall for
# the changes to take affect.
IPV6=yes

# Set the default input policy to ACCEPT, DROP, or REJECT. Please note that if
# you change this you will most likely want to adjust your rules.
DEFAULT_INPUT_POLICY="DROP"

# Set the default output policy to ACCEPT, DROP, or REJECT. Please note that if
# you change this you will most likely want to adjust your rules.
DEFAULT_OUTPUT_POLICY="ACCEPT"

# Set the default forward policy to ACCEPT, DROP or REJECT.  Please note that
# if you change this you will most likely want to adjust your rules
#DEFAULT_FORWARD_POLICY="DROP"
DEFAULT_FORWARD_POLICY="ACCEPT"

# Set the default application policy to ACCEPT, DROP, REJECT or SKIP. Please
# note that setting this to ACCEPT may be a security risk. See 'man ufw' for
# details
DEFAULT_APPLICATION_POLICY="SKIP"

# By default, ufw only touches its own chains. Set this to 'yes' to have ufw
# manage the built-in chains too. Warning: setting this to 'yes' will break
# non-ufw managed firewall rules
MANAGE_BUILTINS=no

#
# IPT backend
#
# only enable if using iptables backend
IPT_SYSCTL=/etc/ufw/sysctl.conf

# Extra connection tracking modules to load. Complete list can be found in
# net/netfilter/Kconfig of your kernel source. Some common modules:
# nf_conntrack_irc, nf_nat_irc: DCC (Direct Client to Client) support
# nf_conntrack_netbios_ns: NetBIOS (samba) client support
# nf_conntrack_pptp, nf_nat_pptp: PPTP over stateful firewall/NAT
# nf_conntrack_ftp, nf_nat_ftp: active FTP support
# nf_conntrack_tftp, nf_nat_tftp: TFTP support (server side)
IPT_MODULES="nf_conntrack_ftp nf_nat_ftp nf_conntrack_netbios_ns"
$ sudo cat /etc/ufw/before.rules
#
# rules.before
#
# Rules that should be run before the ufw command line added rules. Custom
# rules should be added to one of these chains:
#   ufw-before-input
#   ufw-before-output
#   ufw-before-forward
#

# NAT table rules
*nat
:POSTROUTING ACCEPT [0:0]

# Forward traffic through ppp0
-A POSTROUTING -o ppp0 -j MASQUERADE

# don't delete the 'COMMIT' line or these nat table rules won't
# be processed
COMMIT

# Don't delete these required lines, otherwise there will be errors
*filter
:ufw-before-input - [0:0]
:ufw-before-output - [0:0]
:ufw-before-forward - [0:0]
:ufw-not-local - [0:0]
# End required lines


# allow all on loopback
-A ufw-before-input -i lo -j ACCEPT
-A ufw-before-output -o lo -j ACCEPT

# quickly process packets for which we already have a connection
-A ufw-before-input -m conntrack --ctstate RELATED,ESTABLISHED -j ACCEPT
-A ufw-before-output -m conntrack --ctstate RELATED,ESTABLISHED -j ACCEPT
-A ufw-before-forward -m conntrack --ctstate RELATED,ESTABLISHED -j ACCEPT

# drop INVALID packets (logs these in loglevel medium and higher)
-A ufw-before-input -m conntrack --ctstate INVALID -j ufw-logging-deny
-A ufw-before-input -m conntrack --ctstate INVALID -j DROP

# ok icmp codes for INPUT
-A ufw-before-input -p icmp --icmp-type destination-unreachable -j ACCEPT
-A ufw-before-input -p icmp --icmp-type source-quench -j ACCEPT
-A ufw-before-input -p icmp --icmp-type time-exceeded -j ACCEPT
-A ufw-before-input -p icmp --icmp-type parameter-problem -j ACCEPT
-A ufw-before-input -p icmp --icmp-type echo-request -j ACCEPT

# ok icmp code for FORWARD
-A ufw-before-forward -p icmp --icmp-type destination-unreachable -j ACCEPT
-A ufw-before-forward -p icmp --icmp-type source-quench -j ACCEPT
-A ufw-before-forward -p icmp --icmp-type time-exceeded -j ACCEPT
-A ufw-before-forward -p icmp --icmp-type parameter-problem -j ACCEPT
-A ufw-before-forward -p icmp --icmp-type echo-request -j ACCEPT

# allow dhcp client to work
-A ufw-before-input -p udp --sport 67 --dport 68 -j ACCEPT

#
# ufw-not-local
#
-A ufw-before-input -j ufw-not-local

# if LOCAL, RETURN
-A ufw-not-local -m addrtype --dst-type LOCAL -j RETURN

# if MULTICAST, RETURN
-A ufw-not-local -m addrtype --dst-type MULTICAST -j RETURN

# if BROADCAST, RETURN
-A ufw-not-local -m addrtype --dst-type BROADCAST -j RETURN

# all other non-local packets are dropped
-A ufw-not-local -m limit --limit 3/min --limit-burst 10 -j ufw-logging-deny
-A ufw-not-local -j DROP

# allow MULTICAST mDNS for service discovery (be sure the MULTICAST line above
# is uncommented)
-A ufw-before-input -p udp -d 224.0.0.251 --dport 5353 -j ACCEPT

# allow MULTICAST UPnP for service discovery (be sure the MULTICAST line above
# is uncommented)
-A ufw-before-input -p udp -d 239.255.255.250 --dport 1900 -j ACCEPT

# don't delete the 'COMMIT' line or these rules won't be processed
COMMIT
$ cat /etc/sysctl.conf
#
# /etc/sysctl.conf - Configuration file for setting system variables
# See /etc/sysctl.d/ for additional system variables.
# See sysctl.conf (5) for information.
#

#kernel.domainname = example.com

# Uncomment the following to stop low-level messages on console
#kernel.printk = 3 4 1 3

##############################################################3
# Functions previously found in netbase
#

# Uncomment the next two lines to enable Spoof protection (reverse-path filter)
# Turn on Source Address Verification in all interfaces to
# prevent some spoofing attacks
#net.ipv4.conf.default.rp_filter=1
#net.ipv4.conf.all.rp_filter=1

# Uncomment the next line to enable TCP/IP SYN cookies
# See http://lwn.net/Articles/277146/
# Note: This may impact IPv6 TCP sessions too
#net.ipv4.tcp_syncookies=1

# Uncomment the next line to enable packet forwarding for IPv4
net.ipv4.ip_forward=1

# Uncomment the next line to enable packet forwarding for IPv6
#  Enabling this option disables Stateless Address Autoconfiguration
#  based on Router Advertisements for this host
#net.ipv6.conf.all.forwarding=1


###################################################################
# Additional settings - these settings can improve the network
# security of the host and prevent against some network attacks
# including spoofing attacks and man in the middle attacks through
# redirection. Some network environments, however, require that these
# settings are disabled so review and enable them as needed.
#
# Do not accept ICMP redirects (prevent MITM attacks)
#net.ipv4.conf.all.accept_redirects = 0
#net.ipv6.conf.all.accept_redirects = 0
# _or_
# Accept ICMP redirects only for gateways listed in our default
# gateway list (enabled by default)
# net.ipv4.conf.all.secure_redirects = 1
#
# Do not send ICMP redirects (we are not a router)
#net.ipv4.conf.all.send_redirects = 0
#
# Do not accept IP source route packets (we are not a router)
#net.ipv4.conf.all.accept_source_route = 0
#net.ipv6.conf.all.accept_source_route = 0
#
# Log Martian Packets
#net.ipv4.conf.all.log_martians = 1
#

###################################################################
# Magic system request Key
# 0=disable, 1=enable all
# Debian kernels have this set to 0 (disable the key)
# See https://www.kernel.org/doc/Documentation/sysrq.txt
# for what other values do
#kernel.sysrq=1

###################################################################
# Protected links
#
# Protects against creating or following links under certain conditions
# Debian kernels have both set to 1 (restricted)
# See https://www.kernel.org/doc/Documentation/sysctl/fs.txt
#fs.protected_hardlinks=0
#fs.protected_symlinks=0
$ cat /etc/dnsmasq.conf
interface=wlan0
  dhcp-range=192.168.4.2,192.168.4.20,255.255.255.0,24h
$ cat /etc/hostapd/hostapd.conf
interface=wlan0
driver=nl80211
ssid=aaaaa
hw_mode=g
channel=7
wmm_enabled=0
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
wpa=2
wpa_passphrase=bbbbb
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
$ cat /etc/default/hostapd
# Defaults for hostapd initscript
#
# See /usr/share/doc/hostapd/README.Debian for information about alternative
# methods of managing hostapd.
#
# Uncomment and set DAEMON_CONF to the absolute path of a hostapd configuration
# file and hostapd will be started during system boot. An example configuration
# file can be found at /usr/share/doc/hostapd/examples/hostapd.conf.gz
#
#DAEMON_CONF=""
DAEMON_CONF="/etc/hostapd/hostapd.conf"

# Additional daemon options to be appended to hostapd command:-
#       -d   show more debug messages (-dd for even more)
#       -K   include key data in debug messages
#       -t   include timestamps in some debug messages
#
# Note that -B (daemon mode) and -P (pidfile) options are automatically
# configured by the init.d script and must not be added to DAEMON_OPTS.
#
#DAEMON_OPTS=""


#8

設定ファイルを拝見しましたが、特に問題はないようです。

ただ、確かにSSIDとパスワードを上記設定と同じにすると正しく無線LANが設定されないようです。長さを8文字以上に増やしてみてください。こちらではどちらも8文字にすると動作しました。

pi@raspberrypi:~ $ cat /etc/hostapd/hostapd.conf
interface=wlan0
driver=nl80211
ssid=aaaaaaaa
hw_mode=g
channel=7
wmm_enabled=0
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
wpa=2
wpa_passphrase=bbbbbbbbb
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP

#9

サポートありがとうござます。

ssid名とパスワードを8バイトにしたら、再起動後にwlan0がアップしてきて、ノートPCからCANDY_Pi経由で接続できました。これで目的は達成したかと思ったのですが、しばらくしたら落ちたのか、CANDY_PiのオレンジLEDが消えてssid名も見えなくなりました。ただし、wlan0はダウンしていません。

$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether b8:27:eb:b7:fc:38 brd ff:ff:ff:ff:ff:ff
    inet 192.168.2.50/24 brd 192.168.2.255 scope global eth0
       valid_lft forever preferred_lft forever
    inet6 fe80::1964:9bfe:712b:86ab/64 scope link
       valid_lft forever preferred_lft forever
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether b8:27:eb:e2:a9:6d brd ff:ff:ff:ff:ff:ff
    inet 192.168.4.1/24 brd 192.168.4.255 scope global wlan0
       valid_lft forever preferred_lft forever
8: ppp0: <POINTOPOINT,MULTICAST,NOARP> mtu 1500 qdisc noop state DOWN group default qlen 3
    link/ppp

で、もうしばらくしたらCANDY_PiのオレンジLEDが点滅を始めました。
ただし、ssid名は見えないままです。

$ sudo candy service status
● candy-pi-lite.service - CANDY Pi Lite Service, version:6.2.0
   Loaded: loaded (/lib/systemd/system/candy-pi-lite.service; enabled; vendor preset: enabled)
   Active: active (running) since Wed 2018-12-19 17:02:57 JST; 6min ago
 Main PID: 5528 (bash)
   CGroup: /system.slice/candy-pi-lite.service
           tq5528 bash /opt/candy-line/candy-pi-lite/start_systemd.sh
           tq6322 bash /opt/candy-line/candy-pi-lite/start_systemd.sh
           tq6334 pppd /dev/ttySC1 460800 user freetel@freetel.link password freetel connect ''chat -s  ABORT "NO CARRIER" ABORT "ERROR" ABORT "NO DIALTONE" ABORT "BUSY" ABORT "NO ANSWER" "" AT OK ATE0 OK AT+QCFG=\"nwscanmode\",0,1 OK AT+QCFG=\"nwscanmode\" OK ATD*99# CONNECT '' disconnect ''chat -s  ABORT OK ABORT BUSY ABORT DELAYED ABORT "NO ANSWER" ABORT "NO CARRIER" ABORT "NO DIALTONE" ABORT VOICE ABORT ERROR ABORT RINGING TIMEOUT 12 "" \K "" \K "" \K "" +++ATH "" +++ATH "" +++ATH "" ATZ SAY "\nGoodbye from CANDY Pi Lite\n" '' hide-password nocrtscts usepeerdns noauth noipdefault defaultroute ipcp-accept-local ipcp-accept-remote novj novjccomp noccp ipcp-max-configure 30 local lock modem persist maxfail 3 nodetach
           tq6421 python /opt/candy-line/candy-pi-lite/server_main.py /dev/ttySC1 460800 ppp0
           mq9648 python /opt/candy-line/candy-pi-lite/server_main.py /dev/ttySC1 460800 ppp0

12月 19 17:04:44 raspberrypi pppd[6334]: Connect: ppp0 <--> /dev/ttySC1
12月 19 17:04:45 raspberrypi pppd[6334]: CHAP authentication succeeded
12月 19 17:04:45 raspberrypi pppd[6334]: CHAP authentication succeeded
12月 19 17:04:45 raspberrypi pppd[6334]: Could not determine remote IP address: defaulting to 10.64.64.64
12月 19 17:04:45 raspberrypi pppd[6334]: local  IP address 10.63.170.144
12月 19 17:04:45 raspberrypi pppd[6334]: remote IP address 10.64.64.64
12月 19 17:04:45 raspberrypi pppd[6334]: primary   DNS address 210.157.200.37
12月 19 17:04:45 raspberrypi pppd[6334]: secondary DNS address 210.157.200.36
12月 19 17:04:46 raspberrypi server_main.<module>[6421]: [NOTICE] <candy-pi-lite> serial_port:/dev/ttySC1 (460800 bps), nic:ppp0
12月 19 17:04:46 raspberrypi server_main.__init__[6421]: [NOTICE] <candy-pi-lite> RESTART_SCHEDULE_CRON=>[] is ignored

ここでラズパイ3を再起動すると、再びssid名が見えて、ノートPCから接続すればインターネットに出られるようになりますが、すぐにCANDY_PiのオレンジLED点滅がなくなりssid名も見えなくなります。

よくLEDを観察すると、

1.オレンジLED点滅がなくなる
2.緑のLEDも消える
3.緑のLEDが点灯・点滅
4.オレンジLED点滅が始まる

となっています。
ただし、オレンジLED点滅が再度始まってもssidは見えません。


#10

追記です。

Candy Piの電源はラズパイから取っているので、それが原因かなと思い、5V/2AのACアダプターでCandy Piに電源を供給してみましたが、状況は変わらずです。

何回やっても同じなので、再現性はあると思います。


#11

ありがとうございます。
SSIDが消える直接の原因は、モバイル接続が切断されたことのようです。モバイル接続が再度確立した時に、SSIDが表示されないのは何らかの対応が必要と思われます。こちらについては、さらに調査する必要があり、お時間をいただく必要があります。

ところで、モバイル接続が切断されるまでの時間(=オレンジLEDが消えてしまうまでの時間)はどのくらいの時間でしょうか?


#12

ありがとうございます。

モバイル接続が切断されるまでの時間ですが、ノートPCを接続して、そのノートPCがインターネットにアクセスし始めて1分くらいだと思います。なにもしなければモバイル接続は切断されませんが、インターネットに出て行って、Yahooニュースなどを見ると、オレンジLEDの点滅が激しくなり、やがてすべてのLED(オレンジと緑)が消えます。再び、緑とオレンジLEDの点目を始めるには5分くらいかかります。再起動の時と同じくらいです。

頻繁にモバイル接続が切れると困るのですが、USB接続にすれば、ましになるでしょうか?

アクセスに


#13

1分ほどで切断となると、網側(MVNO)との接続で通信モジュールとの相性が悪い可能性があります。

こちらでは、

  • OCNモバイルONE
  • SORACOM Air SIM(国内)
  • IIJモバイル Type I

で動作を見てみましたが、いずれも10分以上動作が確認できています(CANDY Pi Lite+ Dで確認)。
このため、今回の事象を避けるには別のSIMをお試しいただく方が良いと思われます。

もう一点確認ですが、お使いのCANDY Pi Liteの機種は何でしょうか?


#14

ありがとうございます。

使っている通信モジュールはCANDY Pi Lite+ D(赤丸シール)です。

今日もやってみましたが、ノートPCからCANDY Pi Lite+ Dに接続して、Yahooニュースなどを見ると、2~分くらいで通信が切断されました。もっと長いこともありました。ただ接続は必ず切れます。

CANDY Pi Lite+ DではfreetelのSIMは使えないということでしょうか。これまで他のモバイルルーターでは全く問題ありませんでした。

CANDY Pi Lite+で使う場合、freetel以外のSIMなら、切れずにずっと使えるのでしょうか。


#15

状況のご説明ありがとうございます。

そうしますとやはり、大変お手数ですが、別のSIMをご検討いただいた方が良いかと思われます。ただ、残念ながらこちらで全てのMVNOのSIMについて動作を確認しておりませんので、「freetel以外のSIMなら使える」という形では申し上げられないのですが、先に記したSIMについては10分以上通信できることは確認済みです。


#16

ありがとうございます。

CANDY Pi Lite+ DではfreetelのSIMは使えないということで了解しました。
今後、CANDY Pi Lite+ Dのファームアップのバージョンアップで対応する可能性はあるのでしょうか?

また、動作確認されているSIMも10分以上使っていれば、やはり切断することがあるのでしょうか?
その場合、何分くらい正常に通信できるか、目安でいいので教えてください。


#17

大変申し訳ないのですが、残念ながら今回の動作に関わる部分の制御については、当社では手が出せない部分であるため今後対応することはありません。

無線通信であるため、切断の可能性は常にあります。このため正常に通信できる時間については残念ながら、こちらからは提示しかねます。ご期待に添えず申し訳ございません。


#18

わかりました。
ありがとうございます

モバイル接続が切断されて再度確立した時に、SSIDが表示されないトラブルですが、この部分に関しての対策はいかがでしょうか。

ちなみにここ数年、おなじfreetelのSIMを、PIXELA LTE対応USB などのLTE対応SIMフリーなモバイルルーター、いろんなスマホ・タブレットで使っておりますが、このようなトラブルは一度も起きたことがありませんでした。やっぱり相性があるんでしょうか。


#19

追記ですが、

無線通信であるため、切断の可能性は常にあります。
この場合、モバイル接続が再度確立した時も、SSIDが表示されないのでしょうか。
IIJやOCNのSIMを使っていても、モバイル接続が寸断した場合、その度にラズパイの電源をOFFにするか、再起動する必要があるとの認識でいいですか?

たとえば、移動体計測をしている場合、LTEの電波が途切れることはあるのですが、その場合でも、CANDY Pi Lite+はSSIDが消えてしまい、再起動しないと元に戻らないのでしょうか?


#20

SSIDに関しては、何らかの対応ができないか調査しております。
SSIDが消えないようにできないか、あるいはそこまできないにせよ、SSIDが消えた場合に復帰できる方法はないかの2点で検討を進めています。
また、現状においてはLTEの電波が途切れた場合でもSSIDが消えると思われます。