CANDY Pi Lite既存イメージを使ったのセットアップがうまくいかない

マニュアルの手順に沿ってセットアップを行おうとしていたのですが、APNの設定の場面で以下の画像のようなエラーが出てしまい進むことができません。
ご教授のほどよろしくお願いします。

環境
機種:Raspberry Pi 4 Model B 4GB RAM
CANDY Pi Lite D
OS: Raspbian(Ver:10.4)
SIM: iijmio.jp
インストール環境:有線

接続は低速通信をする場合と同じです。

エラー

ご質問ありがとうございます。また、返答が遅くなりまして失礼いたしました。
ご利用環境の以下のコマンドの実行結果を教えていただけますでしょうか。

cat /proc/cpuinfo

よろしくお願いいたします。

返信ありがとうございます。
コマンドを打ちましたところ以下の画像のメッセージが表示されました。
よろしくお願いいたします。

ありがとうございます。おそらくお使いのLinuxカーネルの動作がインストーラー側の想定と異なると思われます。
こちらの方でインストーラーを修正しますのでお待ちください。

インストーラーを更新しました(v8.0.5)。
再度同じ手順でインストールを試していただけますでしょうか。

インストールは完了しましたが、システムの起動がうまくいってないようです。ガイドを参考に再インストールを試みましたが、それもうまくいきませんでした。LEDは点灯しているため認識はしているみたいです。

メッセージからサービスの起動に失敗しているようです。
失敗の詳細を知りたいため、/var/log/syslogにあるログファイルの上記時間帯およびそれ以前のものを投稿いただけますでしょうか。
おそらくなんらかのエラー情報などが入っていると思いますので、ご提供いただければと思います。

スクリーンショットが多くなってしまい大変申し訳ありません。
6枚目の画像の青線の部分が原因ではないかと思います。







ありがとうございます。
Modemが見つからないとのことですが、CANDY Pi LiteはRaspberry Pi 4本体に取り付けられた状態とのことですので、カーネルドライバーが入っていないかあるいはその設定が入っていない可能性があります。

次の$にある行のコマンドを実行してそれぞれの結果を教えていただけますでしょうか。

# 通信モジュールへのシリアルポートの有無
$ ls /dev/ttySC1

# カーネルドライバーのロード状況
$ lsmod | grep sc16is7xx

# シリアルポート向けの設定ファイルの有無
$ ls -la /boot/overlays/sc16is752-spi0-ce1.dtbo

また、念のため以下の情報も教えてください。

# Linuxシステム情報
$ uname -a

# OSリリース情報
$ cat /etc/os-release 

CANDY Pi LiteのGPIOに何か取り付けたりなどはしていますでしょうか。その場合はご利用のGPIOピンをお知らせください。
(ピン番号の参照先:https://www.raspberrypi.org/documentation/usage/gpio/

お待たせしました。
CANDY Pi LiteのGPIOには何もつけておりません。

ありがとうございます。

質問ですが、お使いのRaspbian/Raspberry Pi OSはどのように入手されましたでしょうか?
現状入手可能なOSイメージ(https://www.raspberrypi.org/downloads/raspberry-pi-os/)ではカーネルバージョンは4.19なのですが、いただいた情報ではカーネルバージョンが5.4.51となっております。
アップデートなどされている場合は手順をお知らせいただけますか。

「Raspberry Pi Imager」というものを使いました。その時選択できるOSのなかにRaspbian(32bit)というものがあり、それを選択しました。

バージョン5のカーネルではまだ検証できておりませんので、代わりに以下のサイトからイメージをダウンロードしていただき、Raspberry Pi Imagerで書き込んでもらえますでしょうか。

ダウンロードしてからRaspberry Pi Imagerで書き込むことが可能です。以下の投稿も参考にしていただければと思います。

バージョン5への対応については、別途行うようにいたしますがすぐの対応は難しいので上記にてご利用いただければと思います。

バージョンを下げることで、インストールに成功し、起動も確認できました。
しかし、有線を外すとインターネットに接続ができないのメッセージがでます。
また、SIMカードの認識状態の確認やネットワーク状態の確認のコマンドを打つとエラーがでてしまいます。

初回の起動までには2~3分ほどかかることがあります。モバイルネットワークへ接続されるとボード側のLEDが一定のパターンで光りますのでそれによって接続状態を確認可能です。

起動後10分待ってもオレンジ色のLEDが点滅しません。2,3度インストールを試しても結果は変わりません。有線をつないでいる時はCANDY REDにはつながるのでインストール自体は成功しているとは思うのですが、なぜかLTE回線につながりません。


ログの状態から、以下のことが考えられます。

  1. SIMと契約しているプランのAPNが一致していない
  2. Docomoネットワークではなくau/KDDIまたはSoftbankなど別の携帯電話ネットワーク向けのSIMを利用している

前者については、スマホなどでご利用中のSIMと今回試されているAPNで接続できるかどうかを確認していただけますでしょうか。

後者については、IIJのAPNを指定されていることからIIJをご利用かと思いますが、au/KDDI回線向けのタイプAをご利用の場合はCANDY Pi Lite+ Dではご利用いただけません。ご契約内容を確認いただければと思います。

Kernel 5.4にて動作するソフトウェアをリリースしました。今後最新のRaspberry Pi OSをご利用の際にはこちらもご利用いただけます。

回線契約者様にお問い合わせしたところ、SIMと契約しているプランのAPNが一致していないことが発覚したため、設定のし直しを行ったところ、LTE回線に繋がりました。
長い間、ご教授いただき本当にありがとうございました。

1 Like