デフォルトのAPNを指定してセットアップ中、エラーが発生する

お忙しい中失礼いたします。

貴社製品のCANDY PI Lite LTEを購入し、設定を行っております。

そこで、「デフォルトのAPNを指定してセットアップ」を行うと次のようにエラーが発生します。

この解決方法をご教授願えれば幸いです。
何卒宜しくお願い申し上げます。

ご質問ありがとうございます。
ご利用中のラズパイの機種(Raspberry Pi 3 Model Bなど)を教えていただけますでしょうか。

ラズパイの機種は、Raspberry Pi 3B+。
OSはRasbian、debianバージョンは9.9です。

宜しくお願い致します。

投稿いただいたメッセージの部分より上の部分を見たいのですが、もしあれば投稿していただけますでしょうか。
また、次の2つのコマンドの実行結果を教えていただけますか?

node --version
npm --version

こちらでは9.8のRaspbian(Lite)までしか検証できなかったのですが(こちらのdownloads.raspberrypi.orgサイトから取得)、そちらでは動作しておりました。
おそらくご利用の環境ではソフトウェアの構成が異なると思いますので上記教えていただければと思います。

コマンドを実行してからのログはこちらです。

pi@raspberrypi:~ $ curl -sL https://git.io/v7bXx | sudo bash
[INFO] Using 'python3' command for Python scripts.
main: line 102: warning: command substitution: ignored null byte in input
/usr/bin/python3: No module named pip
[INFO] Installing pip...
Get:1 http://archive.raspberrypi.org/debian stretch InRelease [25.4 kB]
Get:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease [15.0 kB]
Get:3 http://raspbian.raspberrypi.org/raspbian stretch/main armhf Packages [11.7 MB]
Fetched 11.7 MB in 15s (763 kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  gir1.2-glib-2.0 libdbus-glib-1-2 libgirepository-1.0-1 libpython3-dev
  libpython3.5 libpython3.5-dev libpython3.5-minimal libpython3.5-stdlib
  python-pip-whl python3-cffi-backend python3-crypto python3-cryptography
  python3-dbus python3-dev python3-gi python3-idna python3-keyring
  python3-keyrings.alt python3-pyasn1 python3-secretstorage python3-setuptools
  python3-wheel python3-xdg python3.5 python3.5-dev python3.5-minimal
Suggested packages:
  python3-crypto-dbg python-crypto-doc python-cryptography-doc
  python3-cryptography-vectors python-dbus-doc python3-dbus-dbg gnome-keyring
  libkf5wallet-bin gir1.2-gnomekeyring-1.0 python3-pykde4 doc-base
  python-secretstorage-doc python-setuptools-doc python3.5-venv python3.5-doc
  binfmt-support
The following NEW packages will be installed:
  gir1.2-glib-2.0 libdbus-glib-1-2 libgirepository-1.0-1 libpython3-dev
  libpython3.5-dev python-pip-whl python3-cffi-backend python3-crypto
  python3-cryptography python3-dbus python3-dev python3-gi python3-idna
  python3-keyring python3-keyrings.alt python3-pip python3-pyasn1
  python3-secretstorage python3-setuptools python3-wheel python3-xdg
  python3.5-dev
The following packages will be upgraded:
  libpython3.5 libpython3.5-minimal libpython3.5-stdlib python3.5
  python3.5-minimal
5 upgraded, 22 newly installed, 0 to remove and 92 not upgraded.
Need to get 0 B/46.4 MB of archives.
After this operation, 58.5 MB of additional disk space will be used.
apt-listchanges: Reading changelogs...
dpkg: unrecoverable fatal error, aborting:
 files list file for package 'raspberrypi-bootloader' contains empty filename
E: Sub-process /usr/bin/dpkg returned an error code (2)
/usr/bin/python3: No module named pip
[INFO] Installed
/usr/bin/python3: No module named pip
v12.16.3
npm WARN using --force I sure hope you know what you are doing.
[INFO] Installing CANDY RED...
npm ERR! Cannot read property 'resolve' of undefined

npm ERR! A complete log of this run can be found in:
npm ERR!     /root/.npm/_logs/2020-07-16T09_00_40_376Z-debug.log
[ERROR] Failed to install CANDY RED
[ERROR] Consider to use the presinstalled OS image at https://forums.candy-line.io/tags/os, instead.

pi@raspberrypi:~ $ node --version
v12.16.3   
pi@raspberrypi:~ $ npm --version
6.14.4

ありがとうございます。
下記の部分が問題のようです。

apt-listchanges: Reading changelogs...
dpkg: unrecoverable fatal error, aborting:
files list file for package 'raspberrypi-bootloader' contains empty filename
E: Sub-process /usr/bin/dpkg returned an error code (2)

こちらの情報からすると、どうもパッケージの情報が壊れているとのことですが、SDカードの再作成などは可能でしょうか?おそらく通常のパッケージコマンド(例えば、sudo apt-get install python3-pipなど)もうまくいかずエラーとなるはずです。

上記、ご確認いただければと思います。

ご教授いただきありがとうございます。

SDカードのイメージを再構成する事で対応できました!
ありがとうございます。

1 Like